[PATCH] virtio: refactor to use drv_to_virtio
From: Michael S. Tsirkin
Date: Mon Sep 22 2014 - 04:00:39 EST
Use drv_to_virtio instead of open-coding it.
Fix whitespace damage introduced by
virtio: unify config_changed handling
Signed-off-by: Michael S. Tsirkin <mst@xxxxxxxxxx>
---
Note: I'll probably smash this into the previous patch.
drivers/virtio/virtio.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/virtio/virtio.c b/drivers/virtio/virtio.c
index 470b74f..3980687 100644
--- a/drivers/virtio/virtio.c
+++ b/drivers/virtio/virtio.c
@@ -241,8 +241,7 @@ EXPORT_SYMBOL_GPL(unregister_virtio_device);
void virtio_config_changed(struct virtio_device *dev)
{
- struct virtio_driver *drv = container_of(dev->dev.driver,
- struct virtio_driver, driver);
+ struct virtio_driver *drv = drv_to_virtio(dev->dev.driver);
if (drv && drv->config_changed)
drv->config_changed(dev);
--
MST
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/