[PATCH 0/4] mm/page_alloc.c: cleanup on check page
From: Wei Yang
Date: Sun Jan 19 2020 - 08:14:32 EST
The patch set does some cleanup related to check page:
* extract the common part to do check page
* rename two functions for consistent name convention
* remove two unnecessary variable assignments
No functional change.
Wei Yang (4):
mm/page_alloc.c: extract commom part to check page
mm/page_alloc.c: rename free_pages_check_bad() to
check_free_page_bad()
mm/page_alloc.c: rename free_pages_check() to check_free_page()
mm/page_alloc.c: bad_[reason|flags] is not necessary when PageHWPoison
mm/page_alloc.c | 50 ++++++++++++++++++++++---------------------------
1 file changed, 22 insertions(+), 28 deletions(-)
--
2.17.1